WordPress ve PHP Desteği Sınırlaması

Juliette Reinders Folmer, WordPress’in eski PHP sürümü desteğini sabit bir programa yayması için bir teklif yayınladı.

Öneriyi, WordPress’in kurucu ortağı ve proje lideri Matt Mullenweg’in çözümleri tartışmak için iletişime geçmesinin ardından yazdı. Bu, geçen hafta PHP 5.6 desteğini düşürmek ve bu yıl bir sonraki büyük WordPress sürümü için minimum sürümü 7.1’e yükseltmek isteyen bir Trac talebini kapattıktan sonraydı.

Folmer, teklifte esasen iki yol haritası öne sürdü. İlk yol haritası, WordPress’in belirli bir PHP sürümü için desteği hangi aşamada bırakacağına karar verir. Platform, her Aralık ayında beş yıldan daha eski olan bir PHP küçük sürümüne yönelik desteği kaldırmalı. Bu, WordPress’in gelecek büyük sürümüyle aynı zamana denk gelecektir. Aşağıdaki çizelge, her yıl desteklenen minimum PHP sürümünü ortaya koymaktadır:

  • Aralık 2020 – PHP 7.1
  • Aralık 2021 – 7.2 PHP
  • Aralık 2022 – 7.3 PHP
  • Aralık 2023 – 7,4 PHP
  • Aralık 2024 – 8.0 PHP

Teklifin ikinci kısmı, WordPress’e yönelik güvenlik güncellemelerini desteklemek için sürekli bir program oluşturur. Şu anda, WordPress, güvenlik güncellemelerini 3.7 sürümüne kadar yayınlamaktadır. Folmer’ın önerisi benimsenirse, yalnızca önceki dört yıllık WordPress sürümlerini destekleyecektir.

Böyle bir değişiklik, WordPress 5.6 Aralık 2020’de piyasaya sürüldüğünde, WordPress projesinin, Aralık 2016’da piyasaya sürülen WordPress 4.7’ye kadar güvenlik düzeltmelerini desteklemeye adanacağı anlamına gelir.

WordPress’in net beklentiler belirlemesi gerekiyor.

Bu sadece minimum PHP sürümüyle ilgili bir sorun değil – çoğu proje için daha ayrıntılı bir yol haritası istiyor. Bununla birlikte, minimum PHP desteği, çözüm bulabileceğimiz sorunlu bir alandır ve Folmer bir yol çizmiştir. Sadece takip etmemiz gerekiyor.