WordPress PHP 5.2 – 5.5 Desteğini Kaldırdı.

WordPress resmen PHP 5.2 – 5.5 desteğini sona erdirdi ve minimum PHP sürümünü 5.6’ya çıkardı. Geçen Aralık ayında açıklanan plan, 2019 yılının başlarında gerekli olan minimum sürüme geçilmesi ve sonuçlara bağlı olarak, Aralık 2019’da tekrar PHP 7’ye çıkarılmasıydı. PHP 5.5 veya önceki sürümlerde bulunan siteler güvenlik güncelleştirmeleri almaya devam edebilir, ancak en son WordPress sürümüne yükseltme yapamazlar.

Bugün WordPress sitelerinin sadece %2’si PHP 5.2’de kalmaktadır bunun yanısıra kabaca %20’si 5.5 veya daha önceki sürümlerde. WordPress kurulumlarının yaklaşık yarısı PHP 7.0 ve üstü sürümlerde.

Neden WordPress’in direkt PHP 7’yi zorunlu tutmadığını merak ediyor olabilir. Etkisi ve baskın pazar payı ile bu gereksinim kaçınılmaz olarak kullanıcıları yükseltme yapmaya zorlar. Ancak, WordPress’e katkıda bulunanlar, hangi nedenle olursa olsun PHP’yi yükseltmek için daha fazla yardıma ihtiyaç duyan kullanıcıları desteklemeye inanmaktadır.

WordPress geliştiricileri, haberin duyurulmasından sonra çok fazla kutlama tweetleri gönderdi. Her ne kadar PHP 5.6, WordPress’i çalıştırmak için gereken en yeni sürüm olsa da, projenin teknik gereksinim sayfası, kullanıcılarına PHP 7.3 veya daha üstünü kullanmalarını öneriyor. PHP 7+, kullanıcılara muazzam performans kazancı sunar ve geliştiriciler daha modern sözdizimi kullanmak için eklentilerini güncelleyebilir.

 

Site Footer